Unexpected downtime with our Datacenter/ISP proxies in Japan.

Incident Report for IPRoyal

Resolved

This incident has been resolved.
Posted Nov 13, 2025 - 12:47 UTC

Investigating

We are experiencing unexpected downtime with our Datacenter/ISP proxies in Japan.
Posted Nov 13, 2025 - 12:33 UTC
This incident affected: Asia ISP and Asia DC.