Partial outage — North America ISP proxies (Arizona)

Incident Report for IPRoyal

Resolved

This incident has been resolved. Service for the affected portion of our North America ISP proxy pool (Arizona) was restored as of 13:32 UTC. The disruption lasted approximately 30 minutes. We apologize for the inconvenience.
Posted Aug 10, 2026 - 13:37 UTC

Investigating

We are investigating an issue affecting a portion of our North America ISP proxy pool (Arizona). Some customers using ISP proxies in this region may experience connection failures. We will provide updates as more information becomes available.
Posted Aug 10, 2026 - 13:32 UTC
This incident affected: North America ISP.