Temporary Issue with Datacenter proxies in South Africa

Incident Report for IPRoyal

Resolved

This incident has been resolved.
Posted May 19, 2026 - 11:47 UTC

Identified

We are currently experiencing a large-scale DDoS attack affecting parts of our network infrastructure. We understand the disruption this causes and are treating this as a priority incident.

Some customers may experience intermittent connectivity issues, increased latency, or timeouts while mitigation work continues.

Our technical teams are actively working with our DDoS mitigation and upstream network partners to manage the impact. We will continue to share updates as the situation develops.
Posted May 19, 2026 - 09:25 UTC

Investigating

We are experiencing unexpected downtime with our Datacenter proxies in South Africa.

Location: South Africa
Detected: 2026-05-19 08:00 UTC

Our team is actively working to resolve this issue and restore functionality as quickly as possible. We apologize for the inconvenience this may cause and appreciate your understanding.
Posted May 19, 2026 - 09:25 UTC
This incident affected: Africa DC.