North America ISP — partial outage

Incident Report for IPRoyal

Resolved

This incident is resolved. Service has been fully restored. We apologise for the disruption.
Posted Sep 08, 2026 - 04:51 UTC

Investigating

We are investigating a partial outage affecting a specific set of ISP proxy IP addresses in the United States. The affected IP addresses have been intermittently unreachable since approximately 13:44 UTC on 2 September 2026 and are currently unreachable. Other IP addresses, and all other locations in the region, are not affected. Our team is actively looking into it and we will share further updates as we learn more.
Posted Sep 02, 2026 - 14:43 UTC
This incident affected: North America ISP.