Residential Proxy performance degradation

Incident Report for IPRoyal

Resolved

This incident has been resolved. Residential Proxy performance has returned to normal across all regions, and our monitoring confirms stable service. Thank you for your patience.
Posted Jun 04, 2026 - 10:12 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 04, 2026 - 04:14 UTC

Investigating

We are currently investigating reports of degraded performance across our
Residential Proxy network.
Customers may experience slower connection speeds,
increased latency, or intermittent connection failures when using residential
proxies.
Our team is actively investigating the cause and working to restore
normal service. We will share further updates as we learn more.
Posted Jun 04, 2026 - 01:06 UTC
This incident affected: Residential API, Residential Proxies US, Residential Proxies EU, Residential Proxies SG, Residential Proxies JP, and Residential Proxies AU.