Degraded performance — Residential Proxies (Japan)

Incident Report for IPRoyal

Resolved

This incident has been resolved.
Posted Jun 05, 2026 - 04:08 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 05, 2026 - 03:44 UTC

Investigating

We are investigating reports of degraded performance (increased latency and reduced throughput) on our Japan residential proxy pool. Some connections may be slower than usual. Other residential regions are unaffected.
Posted Jun 05, 2026 - 03:24 UTC
This incident affected: Residential Proxies JP.