North America DC — partial connectivity issue

Incident Report for IPRoyal

Resolved

This incident has been resolved. Connectivity for the affected portion of our North America datacenter proxy pool was fully restored as of 09:08 UTC on August 10. We apologize for the inconvenience.
Posted Aug 10, 2026 - 11:56 UTC

Investigating

We are investigating a connectivity issue affecting a small subset of North America Datacenter proxies. The affected IPs are currently unreachable. We will share further updates as we learn more.
Posted Aug 08, 2026 - 23:28 UTC
This incident affected: North America DC.