Scheduled Maintenance for DCH proxies in Greece, Turkey, Israel, Bulgaria, Egipt, Saudi Arabia, Jordan

Incident Report for IPRoyal

Resolved

This incident has been resolved.
Posted Apr 29, 2026 - 13:15 UTC

Investigating

There's upcoming scheduled maintenance for our DCH proxies.

Location: Greece, Turkey, Israel, Bulgaria, Egipt, Saudi Arabia, Jordan
From: 2026-04-29 08:00 UTC
To: 2026-04-29 11:00 UTC

During this period, proxies based in this location may be intermittently unavailable. We appreciate your understanding and apologize for any inconvenience this may cause.
Posted Apr 29, 2026 - 08:19 UTC