Temporary Issue with Datacenter proxies in Asia

Incident Report for IPRoyal

Resolved

This incident has been resolved.
Posted Mar 18, 2026 - 05:12 UTC

Investigating

We are currently experiencing reduced subnet visibility affecting a portion of our Datacenter proxy pool in Asia. As a result, some proxies in this region may be unreachable or returning limited results.

Location: Asia
Detected: 2026-03-17 10:00 UTC

Our team is actively investigating the issue and working to restore full subnet visibility as quickly as possible. We apologize for the inconvenience this may cause and appreciate your understanding.
Posted Mar 17, 2026 - 11:55 UTC
This incident affected: Asia DC.