We are currently experiencing a minor outage affecting ISP proxies in Spain

Incident Report for IPRoyal

Resolved

This incident has been resolved.
Posted Apr 09, 2026 - 08:22 UTC

Investigating

We are currently experiencing a minor outage affecting ISP proxies in Spain due to an ISP-level issue. A subset of Spain exit nodes may be temporarily unavailable or degraded.

Affected resources are being migrated to alternative infrastructure. We expect full restoration shortly.

We will provide updates as the situation progresses. We apologize for any inconvenience.
Posted Apr 09, 2026 - 07:52 UTC
This incident affected: Southern Europe ISP.