Temporary Issue with Residential Proxies in Singapore region

Incident Report for IPRoyal

Resolved

This incident has been resolved.
Posted May 31, 2025 - 05:26 UTC

Investigating

We are currently experiencing unexpected technical difficulties with our Residential proxies in Singapore region. Our team is actively working to resolve this issue and restore functionality as quickly as possible. We apologize for any inconvenience this may cause and appreciate your patience while we address this matter.
Posted May 31, 2025 - 03:32 UTC
This incident affected: Residential Proxies SG.