Temporary Issue with Datacenter & ISP proxies in Australia

Incident Report for IPRoyal

Resolved

This incident has been resolved.
Posted Jun 04, 2025 - 05:44 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 04, 2025 - 05:08 UTC

Investigating

We are experiencing unexpected downtime with our Datacenter & ISP proxies in Australia.

Location: Australia
Detected: 2025-06-03 19:10:00 UTC

Our team is actively working to resolve this issue and restore functionality as quickly as possible. We apologize for the inconvenience this may cause and appreciate your understanding.
Posted Jun 04, 2025 - 04:35 UTC