Scheduled Maintenance for DCH/ISP proxies in Canada, France, Spain, Maroco, Turkey, Greece.

Incident Report for IPRoyal

Resolved

This incident has been resolved.
Posted Jan 19, 2026 - 10:51 UTC

Investigating

There's upcoming scheduled maintenance for our DCH/ISP proxies.

Location: Canada, France, Spain, Maroco, Turkey, Greece.
From: 2026-01-19 08:00 UTC
To: 2026-01-19 12:00 UTC

During this period, proxies based in this location may be intermittently unavailable. We appreciate your understanding and apologize for any inconvenience this may cause.
Posted Jan 19, 2026 - 07:39 UTC