Temporary Issue with Static Residential proxies in United states

Incident Report for IPRoyal

Resolved

Proxies were replaced, affected clients received emails with new proxy details.

Sorry for the inconvenience caused.
Posted Jun 06, 2025 - 19:06 UTC

Investigating

We are experiencing unexpected downtime with our Static Residential proxies in United states.

Location: United states
Detected: 2025-06-06 14:00 UTC

Our team is actively working to resolve this issue and restore functionality as quickly as possible. We apologize for the inconvenience this may cause and appreciate your understanding.
Posted Jun 06, 2025 - 14:16 UTC