Dashboard, API and account access have been restored as of 07:40 UTC. We are monitoring closely to confirm full stability. Proxy connections were unaffected throughout. If you are still seeing errors, please clear your session and log in again, or contact support.
Posted Aug 25, 2026 - 07:49 UTC
Update
Dashboard, API and account access unavailable. We are investigating an issue that is preventing access to the customer dashboard, the API and account management. Customers may be unable to log in, view their accounts or make API calls to the affected endpoints. Proxy connections are not affected. Residential, ISP and Datacenter proxies continue to operate normally — traffic already configured keeps working, and existing proxy credentials keep working.The issue began at approximately 07:10 UTC. Our engineering team is actively working on it and we will post an update within 30 minutes.
Posted Aug 25, 2026 - 07:45 UTC
Investigating
We are currently experiencing technical difficulties with the IPRoyal dashboard. Our team is actively working to resolve this issue and restore functionality as quickly as possible. We apologize for any inconvenience this may cause and appreciate your patience while we address this matter.
Posted Aug 25, 2026 - 07:34 UTC
This incident affected: IPRoyal Customer Dashboard.